Cross-platform PDF digital signing tool. JavaFX desktop UI with drag-to-place visible signatures, PKCS#11/PKCS#12 keystores, RFC 3161 timestamping, OCSP/CRL long-term validation, and a scriptable CLI.
Find trending repositories by name or description.
Cross-platform PDF digital signing tool. JavaFX desktop UI with drag-to-place visible signatures, PKCS#11/PKCS#12 keystores, RFC 3161 timestamping, OCSP/CRL long-term validation, and a scriptable CLI.
A CoAP (RFC 7252) implementation in C
Generate RFC-compliant UUIDs in JavaScript
A ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.
Caterpillar is the ultimate logging system for Deno, Node.js, and Web Browsers. Log levels are implemented to the RFC standard. Log entries can be filtered and piped to various streams, including coloured output to the terminal, the browser's console, and debug files. You can even write your own transforms.
The Network UPS Tools repository. UPS management protocol Informational RFC 9271 published by IETF at https://www.rfc-editor.org/info/rfc9271 Please star NUT on GitHub, this helps with sponsorships!
A go implementation of the STUN client (RFC 3489 and RFC 5389)
PHP URI Template (RFC 6570) supports both URI expansion & extraction
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
RFC (Request for Comments) documents for community feedback on design changes and improvements to PowerShell ecosystem
Minimalist secure text editor and binary encryptor that implements RFC 4880 Open PGP format: symmetrically encrypted, compressed and integrity protected. The editor can protect files with passwords, key files or both.
🔑 Second factor TOTP (RFC 6238) provider for Nextcloud
:hocho: Strictly RFC 3986 compliant URI parsing and handling library written in C99; moved from SourceForge to GitHub
A Kotlin one-time password library to generate "Google Authenticator", "Time-based One-time Password" (TOTP) and "HMAC-based One-time Password" (HOTP) codes based on RFC 4226 and 6238.
Sanck4: Next-generation high-performance Jsonpath framework. Compatible with 'jayway.jsonpath' and IETF JSONPath (RFC 9535) standard specifications (open customization support).
An HTTP cache system, RFC compliant, compatible with @tyktechnologies, @traefik, @caddyserver, @go-chi, @bnkamalesh, @beego, @devfeel, @labstack, @gofiber, @go-goyave, @go-kratos, @gin-gonic, @roadrunner-server, @zalando, @zeromicro, @nginx and @apache
Feature-rich iCalendar/ICS (RFC 5545) parser for Node.js with a robust recurrence rule (RRULE) environment
Expands RFC 6570 URI templates
Pure-Python, zero-dependency TCP/IP stack — Ethernet through RFC 9293 TCP — running in user space on a TAP/TUN interface. Runs as a daemon that drives off-the-shelf programs unmodified through a 1:1 stdlib-socket drop-in, plus a pytcp CLI multitool.
a super FTP/FTPS client library for Rust with full RFC support for both passive and active mode
Tencent Kona SM Suite contains a set of Java security providers, which support algorithms SM2, SM3 and SM4, and protocols TLCP/GMSSL, TLS 1.3 (with RFC 8998) and TLS 1.2.
Framework for representing, validating, querying, and manipulating generic JSON values in Swift 6. Supported are standards such as JSON Text Sequences (RFC 7464), JSON Pointer (RFC 6901), JSON Path (RFC 9535), JSON Patch (RFC 6902), JSON Merge Patch (RFC 7396), and JSON Schema.
🚀 Modern PHP HTTP client inspired by JavaScript's fetch API. Async/await, streaming, SSE, middleware, RFC 7234 caching, and full PSR-7/18 compliance.
🛡️ A lightweight, self-hosted DMARC report parser with a beautiful Vue.js dashboard. Single-binary deployment with IMAP integration, SQLite storage, and RFC 7489 compliance. Built with Go and Vue 3 - no external dependencies required.